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Executive Summary 

This document includes the necessary instructions to install the Oracle Financial Services 

Balance Sheet Planning 8.0.0.0.0 application. You can find the latest copy of this document in 

OTN Documentation Library. 
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1 Preface 

This document provides step-by-step instructions to install the OFS BSP v.8.0.0.0.0 Release. 

1.1 About this Guide 

This manual provides the required information that Balance Sheet Planning Application 

administrator needs to setup the application. The document contains steps to create Hyperion 

Planning Application with BSP specific parameters, Creating Essbase Database, steps for 

creating Balance Sheet Planning relational data model and other required configurations. 

1.2 Audience  

This Manual is meant for use by the Oracle Financial Services Analytical Applications 

Infrastructure System Administrator or Hyperion System Administrator. It provides step-by-step 

instructions necessary for configuring the Oracle Financial Services Balance Sheet Planning 

v8.0.0.0.0 Product.  
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2 Configuring the Environmental Variables  

Set the following environmental variables in the profile for the UNIX user where Hyperion 

Planning has been installed, if not already set: 

 EPM_ORACLE_HOME 

 MIDDLEWARE_HOME 

 HYPERION_HOME - Same as EPM_ORACLE_HOME 

 ORACLE_HOME - Oracle Client Home 

 JAVA_HOME 

 ARBORPATH=$EPM_ORACLE_HOME/products/Essbase/EssbaseServer 

 ESSBASEPATH=$EPM_ORACLE_HOME/products/Essbase/EssbaseServer 

 NLSPATH=$EPM_ORACLE_HOME/products/Planning/bin/nls/msg/en_US/ofsmsg.cat:$EP

M_ORACLE_HOME/products/Planning/bin/nls/msg/C/ofsmsg.cat 

 INIPATH=$EPM_ORACLE_HOME/products/Planning/config 

 FIC_HOME=$EPM_ORACLE_HOME 

 FIC_DB_HOME=$EPM_ORACLE_HOME/logs/bsplog 

 PATH=$JAVA_HOME/bin:$ARBORPATH/bin:$EPM_ORACLE_HOME/products/Planning/b

in:$EPM_ORACLE_HOME/products/Planning/config:$EPM_ORACLE_HOME/products/Pla

nning/lib:$ORACLE_HOME/bin:$PATH:$HOME/bin 

 LD_LIBRARY_PATH=$ORACLE_HOME/lib:$ORACLE_HOME/rdbms/public:$EPM_ORAC

LE_HOME/common/ODBC-

64/Merant/7.1/lib:$EPM_ORACLE_HOME/products/Planning/lib:$ARBORPATH/bin 

 LD_LIBRARY_PATH_64=$LD_LIBRARY_PATH:$LD_LIBRARY_PATH_64 

 ODBCINI=$EPM_ORACLE_HOME/common/ODBC-64/Merant/7.1/odbc.ini 

 ODBCINST=$EPM_ORACLE_HOME/common/ODBC-64/Merant/7.1/odbcinst.ini 

NOTE:  You need to make the changes into the .profile file of the UNIX account where 

Planning and ESSBASE are installed. Oracle client is required on the servers 

where Hyperion ESSBASE and Planning are installed. BSP uses the Oracle 

drivers. 
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3 Prerequisites 

 Hyperion 11.1.2.4 

 Need to have two Database users / schemas. One schema to be used while Data Source 

creation on Hyperion Planning and other one to be used while doing BSP Initialization as 

per below section Initializing Balance Sheet Planning. 

For AIX operating system, execute the slibclean command by root user permission. 

NOTE:  For BSP 8.0, you need to turn on the “Compatibility Mode” on Internet Explorer 

11. 
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4 Installing BSP 8.0.0.0.0 on Hyperion 11.1.2.4 

After installing Hyperion 11.1.2.4, need to do the BSP 8.0.0.0.0 installation. BSP needs to be 

subsequently “initialized” in order to access it. 

If CAPEX and/or WORKFORCE applications are required, initialize CAPEX and/or 

WORKFORCE before BSP initialization.  

NOTE:  The sequence of initialization to be CAPEX and/or WORKSPACE and/or BSP. 

Furthermore, after initializing the CAPEX and/or WORKFORCE modules with BSP, you need to 

perform the following activities. 

 Go to Manage->Dimension->Account and Entity Dimensions 

 Edit “No Entity” and “No Account” members and select the option “BSP”, “Rates” and “Core” 

Plan types. Perform a database refresh. 

4.1 Installing BSP Application 

Use the folowing procedure to install the BSP application: 

1. Download the installer for BSP. Stop all the EPM services. 

2. Copy the downloaded installer to any preferred location on Hyperion Planning server 

and provide necessary (write and execute ) privileges.  

a. Ensure that the logged in unix user has “write” privileges on the Hyperion 

Planning folder structure. 

b. Check if the following environment variables have been set properly before 

invocation:  

JAVA_HOME , ORACLE_HOME , EPM_ORACLE_HOME 

c. Installer supports both GUI and Silent invocations. 

Go to the installer folder through command line and execute any of the below 

command as per choice. 

For Silent Mode invocation, execute the below command: 

 ./setup.sh SILENT 

For GUI Mode invocation, execute the below command through Xmanager, 

Hummingbird or Cygwin etc, which supports the GUI invocation:              

./setup.sh GUI 

3. Provide the required value against the prompted options and proceed. 
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If the prompt – ‘Overwrite Existing file?’ appears, click ‘Yes’ / ‘Yes to All’ to proceed. 

4. Upon completions of the above task as per step 3, execute bsp_webdeploy.sh from 

path $EPM_ORACLE_HOME/bsp. 

5. Provide execute permission and remove CTRL+M characters. Then, execute 

finalize_bsp_install.sh from the path $EPM_ORACLE_HOME/bsp. 

6. Deploy HyperionPlanning.ear  found under 

$EPM_ORACLE_HOME/bsp/ear_to_deploy to the Planning server. 

a. Login to WebLogic Server. Click Deployments. 
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b. Select Planning and click Delete. 

 

c. Click Yes to continue.  

 

d. Click Install. 
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e. Provide the path of .ear file and click Next. 

 

f. Select “Install this deployment as an application” and click Next. 
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g. Click Next. 

 

h. Click Next. 
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i. Click Finish. 

 

j. Click Deployment.  
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The logs will be registered in log file. You can check log files under Diagnostics. 

For more information, refer to Oracle Hyperion Enterprise Performance 

Management System Installation and Configuration Guide. 

NOTE:  Redeployment is being done to include the latest BSP UI changes those are in 

form .jsp , .js, .css files. 

7. If you are installing BSP 8.0 (Hyperion 11.1.2.4) on Solaris, then you need to 

additionally download the patch 10037983 from https://support.oracle.com/ and follow 

the instructions mentioned in Readme of patch 10037983. 

8. Start all the EPM services those are being stopped as in step 1. 

9. Login to workspace URL http://hostname:19000/workspace/index.jsp to create a Data 

Source and application for Balance Sheet Planning as per below mentioned in section 

5.2 through the available options “Manage Data Source” and “Manage Applications” 

respectively under Navigate > Administer > Planning Administration . 

NOTE:  Here, 19000 is the default port on default Installation settings. 

https://support.oracle.com/
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4.2 Creating Hyperion Planning Application 

Select the value of following options in Create Application Wizard as specified below: 

Application Type Generic 

First Fiscal Year Start Year: Set the value as per below illustration. 

If start year falls in a century between: 

 2000-2100 – Then start year will be 2000  

 2100-2200 – Then start year will be 2100 and so 

on. 

Note:  Here, Start year should be any centennial year 

such as, 2000, 2100, and so on. BSP recommends 

using 2000 as the Start year. 

Number of Fiscal Years Any numeric value greater than 5. 

Note: The value provided against “Number of Fiscal 

Years” plus “No Year” members will be created under 

“Years” dimensions. 

“All Years” parent No 

Will your application support multiple currencies? No 

Create 5 Plan Types as given in the next column: Plan Type 1: BSP 

Plan Type 2: Rates 

Plan Type 3: Core 

Plan Type 4: WORKFORCE [WRKFORCE] 

Plan Type 5: CAPEX 

Note: You should create all five Plan Types even if 

you are not planning to use Workforce and/or Capex in 

your implementation. 

After the above steps refresh the Applications list through Navigate > Applications > Refresh. 

After doing refresh, we need to access the newly created application. This can be done through 

Navigate > Applications > Planning > <Created Application Name>. 

Change the Date format in Preferences > Display Options to MM-DD-YYYY  

NOTE:  While creating the Hyperion Planning Application, you can use any Application 

Name. BSP does not place any restriction on the Application naming convention. 

It is recommended to not use any special characters, like &, *, ‘’, ””, %, - and so 

on. 
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4.3 Creating Balance Sheet Planning Relational Data Model 

 Create a tablespace with the user define name. The same table space name should be 

used in user “Configuration” UI for the variable TABLESPACE.  

NOTE:  Here, this tablespace refers to Oracle TABLESPACE and all the output tables of 

Cash Flow Engine will be created in this TABLESPACE. 

 Create Oracle database user for Balance Sheet Planning Relational Data Model in the 

tablespace as created in previous step. This database user should have ‘create’ privileges 

on tablespace it belongs to 

 Ensure that the length of the password you use for creating the Oracle database 

user is below 18-characters. 

 This database user is different than Hyperion configuration database users and 

application data source. 

NOTE:  BSP requires a distinct schema that is different from the schema created for 

creation of an application in Hyperion Planning (which is created in section 5.2 

Hyperion Planning Application Creation). 

 Assign the following specific privileges to the user created for Balance Sheet 

Planning. These privileges are: 

GRANT SELECT_CATALOG_ROLE TO <DBUSERNAME>;  

GRANT CREATE PROCEDURE TO <DBUSERNAME>;  

GRANT CREATE SEQUENCE TO <DBUSERNAME>;  

GRANT CREATE SESSION TO <DBUSERNAME>;  

GRANT CREATE SYNONYM TO <DBUSERNAME>;  

GRANT CREATE TABLE TO <DBUSERNAME>;  

GRANT CREATE TRIGGER TO <DBUSERNAME>;  

GRANT CREATE TYPE TO <DBUSERNAME>;  

GRANT CREATE VIEW TO <DBUSERNAME>; 

4.4 Creating Data Source DSN to Database 

NOTE:  BSP requires only one Data Source, this data-source will point to the Oracle 

schema where the BSP application will be initialized. 

 Open $HYPERION_HOME/common/ODBC-64/Merant/7.1/odbc.ini.  
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 Add a new ODBC Data Source entry pointing to the Oracle-schema into which BSP was 

initialized, in section 5.3 Create Balance Sheet Planning Relational Model. This name 

should later be specified in the BSP’s configuration UI (available in Planning under 

Administrator Activities -> Master Maintenance -> Assumption Forms -> Configuration), as 

mentioned in Section 5 below. 

 The entry should contain information required to connect to the schema created for BSP 

objects.  

 Verify Host Name, Logon ID, Password, Port Number, and SID contain the information 

required to connect to the schema. 
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5 Initializing Balance Sheet Planning 

Use the folowing procedure to initialize Balance Sheet Planning application:  

1. Access the Hyperion Planning using Navigate->Applications->Planning-><Application 

Name>. 

2. -->Properties. 

3. In the Properties window Add new row.  

 Properly Name = APPTYPE Property Value = BSP 

4. Go to Administration > Application > Create Database. 

5. Restart the Planning Sever. 

6. Go to Administration > Application > Manage Application.  

 Chose the Application Name. 

 Proceed for BSP Initialization for the selected application through Actions > 

Initialization > Initialize BSP. 

7. Specify the folllowing parameters: 

 Server: Database Server Name/IP Address  

 Port: Database port 

 Database: Database SID 

 Net Service Name  

 User: Username 

 Password: Password for Database schema 

 Model 

 APS Server: <IPAdress> 

 Languages 

Special character Dot (.) is not allowed in Net Service Name field. Below is a sample screenshot: 
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The Model option (in above sample screenshot) allows you to choose the number of custom 

dimensions that you need for initialization of BSP. This drop-down list has following options:  

 Standard – No additional custom dimensions 

 Custom 1 - One additional custom dimension 

 Custom 2 - Two additional custom dimensions 

The following errors generated to the bsplog.log during Initialize BSP step may be ignored:  

 Error:ORA-00001: unique constraint (PLANBSP.PK_FSI_M_LOOKUP_B) violated.  

 Error:ORA-00001: unique constraint (PLANBSP.PK_FSI_M_LOOKUP_MASTER) violated. 

 Error:ORA-00001: unique constraint (PLANBSP.PK_FSI_M_LOOKUP_TL) violated.  

 Error:ORA-00955: name is already used by an existing object.  

 Error:ORA-01418: specified index does not exist. 

 Error:ORA-01430: column being added already exists in table. 

 Error:ORA-02260: table can have only one primary key.  

 Error:ORA-00911: invalid character 

 Error:ORA-12899: value too large for column.  

"PLANBSP"."FSI_APPLICATIONS"."VERSION" (actual: 11, maximum: 10)  

 Error:ORA-00942: table or view does not exist for table  

“FSI_DIM_ACCOUNT_SETUP_DETAILS”. 

 Error: ORA-02275: such a referential constraint already exists in the table. Add constraint 

FK_FSI_DB_INFO foreign key (SIGNAGE) references FSI_SIGNAGE_CD (SIGNAGE)' 

 Error:ORA-02291: integrity constraint (BSP_PS4_126_C1CST1.FK_FSI_ID_TYPE_MLS_2) 

violated - parent key not found 
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NOTE:  In case you are planning for an integrated installation of BSP with OFSAA 

applications, you should first initialize BSP as a standalone installation and then 

point BSP to the OFSAA instance.  

8. Select “Finish” 

9. After successful initialization, click the “Configure” button to launch the “Configuration 

UI”.  

NOTE:  The config.xml file gets updated automatically as the part of configuration 

process.  

10. Specify values for the parameters as mentioned under “annexure” section and click 

Save. 

11. Edit the file $EPM_ORACLE_HOME/products/Planning/bin/bsp_user_profile.sh 

file to specify the path for ORACLE_HOME variable.  

Note that $MIDDLEWARE_HOME/user_projects/epmsystem1 is the default Planning Instance 

path on default installation.  

In case of change, refer to the relevant path and modify this path against environment variable 

"EPM_ORACLE_INSTANCE" and occurrence of “epmsystem1” in    

$EPM_ORACLE_HOME/products/Planning/bin/bsp_user_profile.sh, 

$EPM_ORACLE_HOME/bsp/BSP_RunOnPlanning.sh, 

$EPM_ORACLE_HOME/bsp/BSP_RunOnEssbase.sh. 

5.1 Set Evaluation Order 

Go to Administration > Dimensions > Evaluation Order tab. 

 For BSP Plan type: 

 Set Chart of Account, Attribute Value and then Account Dimension. 

 For Rates Plan type:      

 Set Rate Element then Mix Breakout Dimension 
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5.2 Steps to Enable Validation Rules 

Follow the below steps to enable the validation rules: 

1. Go to Manage data form open the Loan Fees form and click on column A the 

Loan_Fees_VR Validation rule is enable open this rule and select the Chart of Account 

dimension against attribute of source type in last condition. Then click ok and save the 

form. 

2. Go to Manage data form open the Loan Fees Annual form and click on Grid the 

Loan_Fees_VR, Loan_Fees_VR1, Validation rules are enable open these rules and 

select the Chart of Account dimension against attribute of source type in last condition. 

Then click ok and save the form. 

3. Go to Manage data form open the Deposit Service Charge form and click on Grid the 

Dep_Svc_Chg_VR, Validation rules are enable open this rule and select the Chart of 

Account dimension against attribute of source type in last condition. Then click ok and 

save the form. 

4. Go to Manage data form open the Deposit Service Charge Annual form and click on 

Grid the Dpst_Svc_Chg_Annl_VR, Loan_Fees_VR1, Validation rules are enable open 

these rules and select the Chart of Account dimension against attribute of source type 

in last condition. Then click ok and save the form. 

5. Go to Manage data form open the Synchronization for Balance Accounts form and click 

on Row1 the Syn_Assets_VR, Syn_Liabty_VR, Validation rules are enable open these 

rules and select the Chart of Account dimension against attribute of source type in last 

condition. Then click ok and save the form 

5.3    LCM Export and Preparation for Metadata Synchronization 

1. Post the Loading of Metadata in to BSP Planning Application, the administrator should 

export the Application Metadata to File System in Shared Services. 

2. Administrator has to login into Shared Services and Select the BSP Planning 

Application. 

3. In the Artifact Summary Page at the right Bottom, click Select All. Exclude Essbase 

Data check-box and click Export.   
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4. Here the Administrator defines a LCM Directory Name which has to be provided in 

Configuration Custom UI in the BSP Application. 

5. Once the LCM export is completed, a folder will be created with the given name in 

shared services.  

6. This folder will be located in the import_export path of the Hyperion Instance chosen 

during Installation.  

5.4 Metadata Synchronization 

1. After completing the Preparation for Metadata Sync, Login to the BSP application, 

Select Administrator Activities folder in the left pane. 

2. Select Master Maintenance form and then Right Click on the menu appeared as large 

square box. 

3. From the right click menu Select Metadata Synchronization and choose the type 

needed by the Administrator Purpose. 



 

Oracle Financial Services Software 

23 

6 Creating an Integrated set up for Hyperion/BSP and OFSAAI  

6.1 Pre-requisites 

1. Execute the below SQL on the OFSAA configuration-schema – replace 

$ATOMIC_USER with the name of the OFSAA information-domain schema user. 

Grant select on SETUPINFO to $ATOMIC_USER; 

2. On OFSAAI, applications have been installed and configured.  

3. Installation of BSP has to be completed and BSP has been successfully initialized on 

Hyperion 11.1.2.4 release.  Note down the initialization mode, that is standard or 

custom1 or custom2. 

NOTE:  Once you have configured/mapped the created BSP application to an OFSAA 

atomic schema in an integrated setup as per below mentioned step 3 under 

section Integrating BSP with OFSAAI, then the seeded BSP schema is no longer 

used by the application. 

6.2 Integrating BSP with OFSAAI 

Use the following procedure to integrate BSP with OFSAAI: 

1. Take the BSP ERWIN Model (BSP_Datamodel.erwin from path 

$EPM_ORACLE_HOME/products/Planning/config/bspsql/BSP_Datamodel.erwin) 

and perform the following customizations in ERWIN, as applicable 

a. Merge this model with the ERWIN model of other applications installed on 

OFSAAI. 

b. If CUSTOM1 option was selected in Pre-requisite step #3, modify to merged 

model to add a column called CUSTOM1 in the following super-type objects: 

 BSP_LEAF_COLUMNS 

 LEDGER_LEAF_COLUMNS 

NOTE:  While adding the column, set the UDPs to the same values as that of the 

STRATEGY_ID column. 

c. If CUSTOM2 option was selected in Pre-requisite step #3, modify to merged 

model to add two columns called CUSTOM1 and CUSTOM2 in the following 

super-type objects: 

 BSP_LEAF_COLUMNS 

 LEDGER_LEAF_COLUMNS 
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NOTE:  While adding the columns, set the UDPs to the same values as that of the 

STRATEGY_ID column. 

 Perform an incremental model-upload of this model in OFSAAI, into the 

required information domain. 

2. Execute one of the below mentioned .sql script against OFSAA Atomic Schema from 

path $EPM_ORACLE_HOME/products/Planning/config/bspsql as per opted data model 

type in Pre-requisite step #3. 

Ignore the following errors: 

ORA-01430: column being added already exists in table   

ORA-00955: name is already used by an existing object   

ORA-02260: table can have only one primary key   

ORA-00903: invalid table name         

ORA-00001: unique constraint   

(ALMCUST80ATM.PK_REV_TABLE_CLASS_ASSIGNMENT)     

ORA-02303:   cannot drop or replace a type with type or table dependents         

ORA-02275: such a referential   constraint already exists in the table     

ORA-00911: invalid character   

ORA-00942: table or view does not exist for tables LS_LOAD_TABLE_GTT_V and 

STG_GL_DATA_V 

a. execbspdm_std_integrate_to_ofsaai.sql - if BSP initialization is STANDARD 

b. execbspdm_custom1_integrate_to_ofsaai.sql - if BSP initialization is CUSTOM 1 

c. execbspdm_custom2_integrate_to_ofsaai.sql - if BSP initialization is CUSTOM 2 

NOTE:  These scripts will prompt you for the configuration schema name. Specify the 

name of the configuration-schema followed by a “dot”; for example: 

CONFIGUSER. Also, enter the infodom name. 

Press “Enter” key without giving any value for any prompts other than configuration 

schema and Infodom name. 

3. Login to Planning, launch the BSP Configuration UI and change the database 

username/password/Tablespace values to that of the OFSAA’s atomic schema. Click 

Save and confirm that the settings have been saved successfully. 

4. If setup has any other EPM applications, then edit the config.xml under path: 

$MIDDLEWARE_HOME/user_projects/epmsystem1/Planning/planning1, epmsystem1 

is the default Planning Instance path on default installation.  
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Examples:  

<PARAM DESCRIPTION="Compatible Applications Count" FLAG="N"  

ID="COMPATIBLE_APPSCOUNT">0</PARAM>  

Description: here assumes BSP application is standalone  

 

<PARAM DESCRIPTION="Compatible Applications Count" FLAG="N"  

ID="COMPATIBLE_APPSCOUNT">1</PARAM>  

<PARAM DESCRIPTION="Compatible Applications" FLAG="N"  

ID="COMPATIBLE_APP1">ALM</PARAM>  

 

<PARAM DESCRIPTION="Compatible Applications Count" FLAG="N"  

ID="COMPATIBLE_APPSCOUNT">2</PARAM>  

<PARAM DESCRIPTION="Compatible Applications" FLAG="N"  

ID="COMPATIBLE_APP1">ALM</PARAM>  

<PARAM DESCRIPTION="Compatible Applications" FLAG="N"  

ID="COMPATIBLE_APP2">PFT</PARAM> 

5. If any OFSAA application (such as, ALM, PFT, FTP etc.) has been installed after BSP 

installation, then execute bsp_update_forexistingapps.sql script  under path 

“$EPM_ORACLE_HOME/products/Planning/config/bspsql/insert” on Planning server 

against OFSAA atomic schema.” 

6. In OFSAA, create a new segment called BSP and map this segment to the required 

OFSAA users. This folder will be the container for sharing rules/assumptions between 

ALM/FTP and BSP. 

7. If the default-product dimension in OFSAA is PRODUCT_ID, execute the script 

bsp_preference_product_id.sql from path 

$EPM_ORACLE_HOME/products/Planning/config/bspsql/insert in the atomic schema. 

8. The sliced model upload of BSP will introduce one or more additional leaf dimensions 

into the data model. To reflect these additional dimensions in the respective 

applications, perform the following steps 

a. For OFS ALM: On the OFSAA Atomic schema, drop all tables with the name 

RES_DTL_XXXXX / CONS_DTL_XXXX – re-execute the relevant ALM 

Processes to regenerate the tables. 
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b. For OFS PFT: In the OFSAA Information Domain, open and resave all the OFS-

PFT allocation rules so that the new leaf-dimensions are referenced properly 

9. Edit $EPM_ORACLE_HOME/products/Planning/bin/bsp_user_profile.sh to 

specify the correct path for ORACLE_HOME.  

10. Modify the entry made earlier in odbc.ini & point it to the OFSAA Atomic Schema. 

The odbc.ini file is usually found under $EPM_ORACLE_HOME/common/ODBC-

64/Merant/7.1/ folder. 

11. Restart all the Hyperion services. 

6.3 Limitations 

1. The Time Buckets cannot be shared across OFSAAI and BSP applications. The user 

has to create the required Time buckets to be used for BSP through BSP UI and the 

user should not EDIT / modify these newly defined time buckets through OFSAAI UI. 

2. The defined Forecast rates cannot be shared across in ALM and BSP, because of 

hybrid nature of forecast rates sys id generated in BSP. 

3. The currencies created through BSP UI cannot be edited through OFSAAI UIs and vice 

versa. 

4. BSP does not support Breakage Charges as adjustment type. 

The Adjustment Rule definitions created through OFSAAI UIs, having Adjustment Method as 

Formula Based Rate and Assignment date as Origination Date only will be viewable / editable in 

BSP. 
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7 Setting up Distributed Environment 

Perform the below steps when Hyperion Planning is installed in a distributed manner, that is, the 

Hyperion components Planning and ESSBASE are installed on separate servers. 

Note the following:  

 Hyperion ESSBASE should not be installed on Windows. 

 Hyperion ESSBASE and Hyperion Shared Services must be installed on the same UNIX 

Server. 

 The OS/Version of the server where Planning is installed must be the same as the 

OS/Version of the server where ESSBASE is installed. 

 Steps mentioned below should be repeated after every: 

1. Initialization/re-initialization of Hyperion Planning generic application(s) created for 

Balance Sheet Planning using “Administration > Application > Manage Application”.  

2. Update of Configuration settings for Balance Sheet Planning using “Master 

Maintenance > Assumption Forms > Configuration”. 

Perform the following steps, in the given sequence: 

1. Ensure that tnsnames.ora on the ESSBASE Server is configured with the same name 

as on the Planning server, to connect to the database specified during initialization of 

BSP.  

2. Copy the $EPM_ORACLE_HOME/common/ODBC-64/Merant/7.1/odbc.ini from the 

Planning server to the corresponding folder on ESSBASE Server, and update the 

odbc.ini for driver path for the BSP-specific entry. 

3. Save the Configuration Parameters in Planning; while saving the configuration, make 

sure that LCMDIRPATH is the LCM export path as on the ESSBASE server. 

4. Give execute permissions to “BSP_RunOnPlanning.sh” that is present at 

$EPM_ORACLE_HOME/bsp location on the Planning server and run the script without 

passing any parameters. The script will create a gzip archive “bsp.tar.gz” in the same 

folder.  

5. Copy “BSP_RunOnEssbase.sh” and “bsp.tar.gz” from $EPM_ORACLE_HOME/bsp to 

$EPM_ORACLE_HOME in ESSBASE Server, to where ESSBASE is installed. 

6. Give execute permissions to “BSP_RunOnEssbase.sh” and run the script without 

passing any parameters. 

7. On the ESSBASE server, modify bsp_user_profile.sh present under 

$EPM_ORACLE_HOME/products/planning/bin folder and set the ORACLE_HOME as 

appropriate. 
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NOTE:  $MIDDLEWARE_HOME/user_projects/epmsystem1 is the default Planning 

Instance path on default installation.  

Incase of change, refer to the relevant path and modify the path against environment variable 

"EPM_ORACLE_INSTANCE" and occurrence of “epmsystem1” in the following:   

 $EPM_ORACLE_HOME/products/Planning/bin/bsp_user_profile.sh,  

 $EPM_ORACLE_HOME/bsp/BSP_RunOnPlanning.sh,  

 $EPM_ORACLE_HOME/bsp/BSP_RunOnEssbase.sh.                    
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8 Language Pack Installation and Configuration 

8.1 Installation 

Download the Balance Sheet Planning Version 8.0.0.0.0 language pack OPatch released against 

the bug 10037983 and apply it by following the steps mentioned in Readme.txt. 

NOTE:  Changing of "Name" of any language conversion dimension member is not 

supported as it will impact the business logic.  You may, however, change 

Aliases.  Aliases can be changed in Planning, using the menu option : 

Administration > Manage > Dimensions. 

8.2 Configuration 

1. Verify that the environment variable LANG is set to the required language. This 

language will be used during initialization of Balance Sheet Planning application. 

2. Create an application in Hyperion Planning using Manage Application option.  

3. Add an application property, APPTYPE with value BSP. 

4. Go to option Administration > Manage > Alias Tables.  

5. Add an alias table for the respective language as per the below table:  

German German 

Spanish Spanish 

French (Canada) French (Canada) 

French French 

Italian Italian 

Japanese Japanese 

Korean Korean 

Portuguese Portuguese 

Russian Russian 

Chinese-Simplified Chinese-Simplified 

Chinese-Traditional Chinese-Traditional 

English Default 

6. Once the alias table is created, go to the option, Administration > Application > Settings 

and select "Current Application Defaults" tab.  
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7. In Alias Setting, select the newly created alias table and save.  

8. Now, trigger the Create Database option for the new application created. Note: All other 

steps for BSP application initialization will remain the same. 

8.3 User Browser Settings 

Follow these steps to enable the settings in Browser (Internet Explorer): 

1. Navigate to Tools > Internet Options. 

2. Under the General tab, click Languages to display the Language Preference window. 

 

3. Click Add to display the Add Language window. 



 

Oracle Financial Services Software 

31 

 

4. Select the installed Language Pack from the list. You can press and hold Ctrl key for 

multiple selections. Click OK. 

5. In the Language Preference window, select the language and click Move up to make it 

the first language in the order of preference. 

6. Click OK in the Language Preference window and again click OK in Internet Options 

window to save the settings and exit. 



 

Oracle Financial Services Software 

32 

9 Annexure  

9.1 List of Parameters 

Sr. No. Parameter Name Description 

1 PASSWORD Database Password 

2 USERNAME Database User 

3 DSNNAME DSN Name  (value should be the system DSN name configured 

for ODBC) 

Note: You should use the same DSN name which is created 

using section 4.4. 

4 SERVERNAME Essbase Server Name 

5 ESSUSER Essbase User Name 

6 ESSPWD Essbase Password 

7 LCMDIRPATH LCM Directory path 

8 LCMDirName LCM Directory Name   

Note: You can use underscore ("_”) in LCM Directory Name, but 

hyphen ("-") is not allowed. 

9 FirstYr First Year 

10 EndYr End Year 

11 CurrMonth Current Month 

12 StartPeriod Start Period (By Default set to Jan) 

13 EndPeriod End Period  (By Default set to Dec) 

14 TABLESPACE DB Table Space 

9.2 Setting of Substitution Variable 

NOTE:  If you are attempting to open a Form in BSP and following error appears: "A 

substitution variable required for this calculation is undefined. Variable: 

SecondYr", then set the SecondYr variable in Essbase Administration Services. 

SecondYr is a substitution variable. Any other variable can also be appeared in the above error 

message. Follow the below steps to configure the variable: 

1. Log in to EAS Console: http://<hostname>:19000/easconsole. 
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2. Click on "Launch". 

3. The Essbase Administration Services console will open. 

4. Expand Enterprise View -> Essbase Servers. 

5. Right-click on your server -> Edit -> Variables. 

 

6. The Substitution Variables window will open. Go to the variable you are looking for and 

double-click on the value. 

7. Enter the value and click on Set. 
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8. Go back to BSP, and reload the Form. 

NOTE:  Logout and Login are not required. 

9.3 Examples of config.xml and tnsnames.ora 

9.3.1 config.xml 

<PARAM DESCRIPTION="Database service name:Port Number/SID" FLAG="N" 

ID="SID">ORCL</PARAM> 

<PARAM DESCRIPTION="Net Service Name" FLAG="N" ID="TNS">ORCL</PARAM> 

For example: 

<PARAM DESCRIPTION="myhost.oracle.com:1521/ORCL" FLAG="N" 

ID="SID">ORCL</PARAM> 

9.3.2 tnsnames.ora 

ORCL = 

 DESCRIPTION = 

 (ADDRESS_LIST = 

 (ADDRESS = (PROTOCOL = TCP)(HOST = myhost.oracle.com)(PORT = 1521)) 
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 ) 

 (CONNECT_DATA = 

 (SID = ORCL) 

 (SERVER = DEDICATED) 

 ) 

 ) 

NOTE:  You should access the Configuration UI and enter the details in this UI manually 

and Save. Also, verify these details with respect to odbc.ini file. The 

$EPM_ORACLE_HOME/bsp/BSP_RunOnPlanning.sh and 

$EPM_ORACLE_HOME/bsp/BSP_RunOnEssbase.sh scripts must be also be run 

after making these updates in a distributed environment.  For more information, 

refer to the BSP 8 User Guide. 

9.3.3 List of Log files 

 bsplog.log: This is being written BSP initialization and all Assumption Forms UI related 

log statements. 

 BSPCalculation_UnpricedAcc_udf.log: This is being written with while user is 

executing new Business and Current Business. 

 Config_FileCall.log: This is being written with statements related to Database access 

and import rule data load activities during various BSP business rule executions. 

 Data_Export.log: This is being written with statements related to exported data during 

various BSP business rule executions. 

 DBProcsFuncs_PAttrs_Call.log: This is being written with statements for executed 

database procedures and functions during BSP business rule executions. 

 Metadata_Sync.log: This is being written with statements for Metadata Synchronization 

activities invoked through BSP business rules. 

In Single tier setup: 

 BSP generates all log files under path $EPM_ORACLE_HOME/logs/bsplog. 

 BSP generates all Cash flow engine related log files as part of Cash Flow Edit run , New 

business and Current business execution under path 

$EPM_ORACLE_HOME/logs/bsplog/log/FusionApps. 

 

 

 

http://docs.oracle.com/cd/E88859_01/homepage.htm
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In Distributed setup: 

On Planning Server: 

 BSP generates BSP Initialization process  and all Assumption Forms UI related log 

statements in $EPM_ORACLE_HOME/logs/bsplog/bsplog.log. 

 BSP generates all Cash Flow Edit runs log statements under path 

$EPM_ORACLE_HOME/logs/bsplog/log/FusionApps. 

On Essbase Server:    

 BSP generates all Business Rule execution related log files under path 

$EPM_ORACLE_HOME/logs/bsplog. 

 BSP generates all Cash flow engine related log files as part of New business and Current 

business execution under path $EPM_ORACLE_HOME/logs/bsplog/log/FusionApps. 

Following tables capture the intermediate stages on database side: 

 fsi_bsp_process_log: This is a BSP specific table to capture intermediate state, 

success and failure message of individual procedure / function executions through BSP 

business rules. 

 fsi_process_errors: This is a OFSAAI table which maintains the various information 

related to Cash flow engine invocations through New business, Current Business, Cash 

flow edit process runs. 

 fsi_message_log: This is a OFSAAI table which maintains the various information 

related to hierarchy members’ registration process. 
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